Debian Lenny: Instalación de Codecs


debian_lennyComo sabemos, muchos de los codecs no vienen por defector en Debian porque eston no son libres, pero podemos instalarlos desde el repositorio creado por Marillat para reproduccion de mp3,  dvds y videos.

En esta ocación les voy a contar como realice la instalación de codecs para Debian Lenny, en mi caso para la Notebook.

Primero abrimos con nano u otro editor

$ sudo nano /etc/apt/surces.list


y agregamos los repositorios segun nuestro Debian (solo uno, dependiendo si es estable, testing o inestable)

deb http://www.debian-multimedia.org stable main
deb http://www.debian-multimedia.org testing main
deb http://www.debian-multimedia.org unstable main

Luego le damos actualizar

 $ sudo aptitude update
$ aptitude install debian-multimedia-keyring

Luego de este paso puede ser que tengamos problemas con las llaves publicas, entonces tenemos que instalar las llaves de debian multimedia que se encuentran en el mismo sitio.

Descargamos el paquete de llaves

$ wget http://ftp.mgts.by/debian-multimedia/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2008.10.16_all.deb

O simplemente descargamos desde un navegador luego

con cd nos dirigimos donde descargamos el paquete y ejecutamos

$ dpkg -i debian-multimedia-keyring_2008.10.16_all.deb

Una vez instalado todo, ya podemos descargar nuestros codecs

sudo aptitude install libfaad2-0 libmp4-0 libfaac0 alsamixergui
toolame lame libmp3lame0 libdvdnav4 libdvdread3 libdvdcss2 w32codecs 
avifile-divx-plugin ffmpeg

Para 64 bits

<code># aptitude install libfaad2-0 libmp4v2-0 libfaac0 alsamixergui
toolame lame libmp3lame0 libdvdnav4 libdvdread3 libdvdcss2 w64codecs
avifile-divx-plugin ffmpeg</code>

Con esto deberiamos tener los codecs a full, espero les haya servido, nos vemos, cualquier cosa avisen.

Fuentes

http://www.esdebian.org
http://debian-multimedia.org/

13 comentarios to “Debian Lenny: Instalación de Codecs”

  1. Ernesto Says:

    me fue muy util, gracias.

  2. yaotzin Says:

    hmmm, todo va bien hasta que intento descargar los codecs, me dice que libmp4-0 y otros no existen….

    • raulespinola Says:

      Si puede llegar a suceder, lo que pasa es que los nombres de las librerias pueden cambiar ya sea por nuevas versiones u otros temas, proba buscarlo con el comando apt-cache search libmp4 (lo acabo de probar en ubuntu y encuentra algunos) o desde el synaptics, no te olvides de agregar los repos.
      Disculpa la tardanza. avisa cualquier cosa.

  3. Si, funciona.

  4. Si, funciona. Debian forever.
    Un saludo

  5. Hola, muy buenas,

    estoy intentando probar el Ekiga y el Empathy en Linux y por más que le doy vueltas no consigo que me incluyan los códecs H.263 y/o H.263+….

    De veras que ya no sé qué hacer; está claro que se trata de algún error de incompatibilidad, porque tengo ffmpeg instalado. Además he incluido el repositorio de debian-multimedia y no me ha servido de nada…instaló de nuevo alguna librería
    (“Se actualizarán los siguientes paquetes:
    ffmpeg libavcodec51 libavdevice52 libavutil49 tzdata “), pero nada, el Ekiga sigue soportando únicamente H.261 y THEORA.

    El caso es que tengo Asterisk rulando el mismo host…¿puede venir por ahí el problema? Es que ya no sé qué hacer…

    Muchas gracias por anticipado.

    • raulespinola Says:

      Hola Paco, mira realmente te pido disculpas no creo que pueda ayudarte, ya que soy solo usuario de ekiga y no tengo mucho conocimiento sobre Asterix, te recomiendo que averigues en un foro sobre Asterix, ya que por ahi puede venir el problema pero googleando seguro lo vas a encontrar.

  6. Gracias por contestar tan rápido, de verdad.

    El caso es que Asterisk no tiene o no debería tener nada que ver, puesto que lo puedo deshabilitar cuando quiera (parar su ejecución, vamos) De hecho, he estado probando el SIP-Communicator y funciona sin problemas con H.263, así que debería tratarse de alguna cuestión relacionada con Ekiga (versión 3.0.1)

    No sé…supongo que tendré que pasar a otro softphone, porque con Ekiga ya no se me ocurre qué hacer. El problema es que con el Empathy supongo que sucede lo mismo (porque deben tener una estructura muy similar)

    Bueno, gracias de todos modos.

    Un saludo,

    Paco

  7. hola, gracias por el tutorial, puedo instalar todo menos :
    libmp4-0

    esto e slo que me tira la tarminal:

    … Leyendo las descripciones de las tareas… Hecho
    No se encontró ninguna versión candidata para libmp4-0
    No se encontró ninguna versión candidata para libmp4-0
    No se instalará, actualizará o eliminará ningún paquete.
    0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
    Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B…

    que onda? alguien mas tuvo el mismo problema?

  8. Gracias por este aporte. son los que me ayudan muchisimo y me gustan porque son puntualizados.

  9. Si no encontró los w32codecs, entonces descargarlo de aquí:
    http://www.debian-multimedia.org/dists/lenny/non-free/binary-i386/package/w32codecs.php
    … y después instalarlo así:

    servidortop:/home/xristian# dpkg -i w32codecs_20110131-0.1_i386.deb

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: